Setting up a home lan – edge router configuration

Hi

I’m using a small Cisco 891 that has an 8 port switch built-in and Putty to connect to the console port of the router, a console cable and a USB>console adapter.

Prior to this config, I configured an LTE dovado router in bridge mode so that I can get a public IP address on the wan interface on Cisco. To do this, you need to get the public IP service from your LTE provider and set your LTE router in bridge mode.

This is a basic config that I will expand weekly to imitate a small office LAN:

!!! this sets the hostname
hostname EdgeRouterHome

!!! this will give your LAN device necessary IP addresses
ip dhcp pool lanpool
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
!

!!! this is a domain name
ip domain name HOMEDOMAIN

!!! this makes sure that the router archives its config to an tftp server that I set up on a home PC (any free tftp software will do).
archive
log config
hidekeys
path tftp://192.168.1.224/configs/$h-$t
write-memory
!

!!! this is a port to my home PC, i use vlan 10 for my main lan
interface FastEthernet1
switchport access vlan 10
no ip address

!!!this is the wan (internet facing) interface. I use dhcp to get the public address from my Dovado, i use nat to translate private addresses on my lan to the public address on the wan interface. Otherwise, i would get no internet access on my PC!!!!
interface GigabitEthernet0
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!

!!! this is my lan subnet. nat inside is used to mark this part of the router as inside. virtual-reassembly is an automatic command to reassemble all packets before translation!!!!
interface Vlan10
description homelan
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in

!!! this command makes router do NAT. Overload means all internal addresses are translated to the one public address. source list 101 refers to the access-list that specifies what internal subnet is !!!
ip nat inside source list 101 interface GigabitEthernet0 overload
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
!!! ntp server is to set time on my router. I will need this later on!!!
ntp server ntp1.tp.pl

With this simple config, I have a working home lan! Easy peasy lemon squeezy!

Next time on NetAdmins: we’ve configured the home lan but is it actually working? How to verify that everything is working fine using show commands? And, most importantly, what did we not configure? Enter the paranoid Sam Cisco who will verify and foolproof the config.

Skomentuj

Wprowadź swoje dane lub kliknij jedną z tych ikon, aby się zalogować:

Logo WordPress.com

Komentujesz korzystając z konta WordPress.com. Wyloguj /  Zmień )

Zdjęcie na Google

Komentujesz korzystając z konta Google. Wyloguj /  Zmień )

Zdjęcie z Twittera

Komentujesz korzystając z konta Twitter. Wyloguj /  Zmień )

Zdjęcie na Facebooku

Komentujesz korzystając z konta Facebook. Wyloguj /  Zmień )

Połączenie z %s