GRE backup tunnels

Hi

Today I actually learnt something new. Let’s imagine we have a remote branch with two internet connections: one broadband (Flat rate) and one pay-as-you-go 4g connection. You want redundancy but you don’t want to pay too much for your pay-as-you-go connection so you set up a primary tunnel on the broadband (tunnel100) to be always UP and a backup GRE tunnel on the 4g connection (tunnel45) but ONLY if the primary link fails.

interface Tunnel100
backup delay 3 60
backup interface Tunnel45
ip address 155.100.0.5 255.255.255.0
tunnel source 155.1.100.5
tunnel destination 155.1.100.4
end
interface Tunnel45
ip address 155.45.0.5 255.255.255.0
tunnel source 155.1.45.5
tunnel destination 155.1.45.4
end

R5#show run | i ip route
ip route 150.1.4.4 255.255.255.255 155.100.0.4 10
ip route 150.1.4.4 255.255.255.255 155.45.0.4 20

  1. Normal state:

R5#show backup
Primary Interface Secondary Interface Status
—————– ——————- ——
Tunnel100 Tunnel45 normal operation

2. Tunnel100 fail, Tunnel 45 UP state:

R5#show backup
Primary Interface Secondary Interface Status
—————– ——————- ——
Tunnel100 Tunnel45 backup mode

3. Transition after tunnel 100 is back up, but before 60 seconds have elapsed

R5#show backup
Primary Interface Secondary Interface Status
—————– ——————- ——
Tunnel100 Tunnel45 waiting to revert (44 more seconds)

Because these are GRE tunnels, it would be good to enable keepalives, so that interface down on one router means that the tunnel also goes down on the other end. Otherwise R4 may have tunnel100 down, but R5 will still have tunnel100 UP. Traffic will then be blackholed.

 

Skomentuj

Wprowadź swoje dane lub kliknij jedną z tych ikon, aby się zalogować:

Logo WordPress.com

Komentujesz korzystając z konta WordPress.com. Wyloguj /  Zmień )

Zdjęcie na Google

Komentujesz korzystając z konta Google. Wyloguj /  Zmień )

Zdjęcie z Twittera

Komentujesz korzystając z konta Twitter. Wyloguj /  Zmień )

Zdjęcie na Facebooku

Komentujesz korzystając z konta Facebook. Wyloguj /  Zmień )

Połączenie z %s