Multicast tshooting fail

Hello

Just found something funny when fighting multicast labs. I’ve joined an igmp group on R6 and I was trying to ping it from R10 but getting no responses from R6.

I enabled debugging and saw these mysterious entries. Google is not (!!!) helpful at all with this.

R6#debug ip mfib pak
MFIB IPv4 pak debugging enabled for default IPv4 table
R6#
MFIBv4(0x0): Pkt (155.1.108.10,239.6.6.6) (FS) lookup miss, dropping
R6#
MFIBv4(0x0): Pkt (155.1.108.10,239.6.6.6) (FS) lookup miss, dropping
R6#
MFIBv4(0x0): Pkt (155.1.108.10,239.6.6.6) (FS) lookup miss, dropping
R6#
MFIBv4(0x0): Pkt (155.1.108.10,239.6.6.6) (FS) lookup miss, dropping
R6#
MFIBv4(0x0): Pkt (155.1.108.10,239.6.6.6) (FS) lookup miss, dropping
R6#
MFIBv4(0x0): Pkt (155.1.108.10,239.6.6.6) (FS) lookup miss, dropping

It was a multiaccess ethernet interface and when I joined this group on another router, I was getting responses from the other router so there had to be something wrong with R6.

And of course, there was.

R6#show ip mroute
IP Multicast Forwarding is not enabled.
IP Multicast Routing Table
Flags: D – Dense, S – Sparse, B – Bidir Group, s – SSM Group, C – Connected,
L – Local, P – Pruned, R – RP-bit set, F – Register flag,
T – SPT-bit set, J – Join SPT, M – MSDP created entry, E – Extranet,
X – Proxy Join Timer Running, A – Candidate for MSDP Advertisement,
U – URD, I – Received Source Specific Host Report,
Z – Multicast Tunnel, z – MDT-data group sender,
Y – Joined MDT-data group, y – Sending to MDT-data group,
G – Received BGP C-Mroute, g – Sent BGP C-Mroute,
N – Received BGP Shared-Tree Prune, n – BGP C-Mroute suppressed,
Q – Received BGP S-A Route, q – Sent BGP S-A Route,
V – RD & Vector, v – Vector, p – PIM Joins on route
Outgoing interface flags: H – Hardware switched, A – Assert winner, p – PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

 

I think that this is the real value of doing these labs. You learn stuff the hard way. But why oh why does IOS not shout that multicast is not enabled if you join an igmp group on it?

Skomentuj

Wprowadź swoje dane lub kliknij jedną z tych ikon, aby się zalogować:

Logo WordPress.com

Komentujesz korzystając z konta WordPress.com. Wyloguj /  Zmień )

Zdjęcie na Google

Komentujesz korzystając z konta Google. Wyloguj /  Zmień )

Zdjęcie z Twittera

Komentujesz korzystając z konta Twitter. Wyloguj /  Zmień )

Zdjęcie na Facebooku

Komentujesz korzystając z konta Facebook. Wyloguj /  Zmień )

Połączenie z %s